Providing resources for people with a passion for Christ and the web

Browsing this Thread:   1 Anonymous Users





News feed does not work ?
Just popping in
Joined:
2009/5/5 20:26
Group:
Confirmands
Posts: 3
Offline
hi

It seems that this feed does not return information
http://christianwebresour ... ?feed=news

Posted on: 2009/5/19 21:29
Transfer the post to other applications Transfer


Re: News feed does not work ?
Webmaster
Joined:
2007/6/15 11:53
Group:
Site Maintainers
Confirmands
Posts: 195
Offline

Thanks for the notice - the feed is working again. There was an invalid character in one of the articles causing the problem. I should learn not to copy/paste text from other sources.


(I also need to work on the HTML in the forum signatures)


Posted on: 2009/5/19 21:41
_________________
Steve
"Whether you turn to the right or to the left, your ears will hear a voice behind you, saying, "This is the way; walk in it." Isaiah 30:21
Transfer the post to other applications Transfer


Re: News feed does not work ?
Just popping in
Joined:
2009/5/5 20:26
Group:
Confirmands
Posts: 3
Offline
Thanks for correction ... and for your dev work !

@+

Posted on: 2009/5/19 21:47
Transfer the post to other applications Transfer


Re: News feed does not work ?
Just popping in
Joined:
2009/5/5 20:26
Group:
Confirmands
Posts: 3
Offline
Again me !

For html in your sig, you should test this hack.

In kernel/user.php
Quote:


function XoopsUser($id = null)
{
$this->initVar('uid', XOBJ_DTYPE_INT, null, false);

[...]

$this->initVar('user_mailok', XOBJ_DTYPE_INT, 1, false);
// hack
$this->initVar('dohtml', XOBJ_DTYPE_INT, 1, false);

[...]
}



And in userinfo.php

Quote:


$xoopsTpl->assign('lang_signature', _US_SIGNATURE);
// edit
// $xoopsTpl->assign('user_signature', $myts->makeTareaData4Show($thisUser->getVar('user_sig', 'N'),0,1,1));
$xoopsTpl->assign('user_signature', $myts->makeTareaData4Show($thisUser->getVar('user_sig', 'N'),1,1,1));

if ($thisUser->getVar('user_viewemail') == 1) {



I have made no test. Hope it still work (original hack was made for an old Xoops version)

@+

Posted on: 2009/5/19 21:54
Transfer the post to other applications Transfer


Re: News feed does not work ?
Webmaster
Joined:
2007/6/15 11:53
Group:
Site Maintainers
Confirmands
Posts: 195
Offline

Thanks for the tip.

Actually, it's not an issue with the core, it is with the module(s) that filter HTML on output, too - CBB is one of them. It was discussed in the ImpressCMS forums - http://community.impressc ... mp;forum=1

BTW - any makeTareaData4... or makeTboxData... method is outdated. Replace with the proper method as indicated in class/module.textsanitizer.php


Posted on: 2009/5/20 9:30
_________________
Steve
"Whether you turn to the right or to the left, your ears will hear a voice behind you, saying, "This is the way; walk in it." Isaiah 30:21
Transfer the post to other applications Transfer






You can view topic.
You cannot start a new topic.
You cannot reply to posts.
You cannot edit your posts.
You cannot delete your posts.
You cannot add new polls.
You cannot vote in polls.
You cannot attach files to posts.
You cannot post without approval.

[Advanced Search]


Bookmark and Share!

Join Us On Facebook